安装openssh-server失败问题

安装openssh-server出现问题,提示

下列软件包有未满足的依赖关系: openssh-server : 依赖: openssh-client (= 1:6.6p1-2ubuntu1) E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

解决办法

  • 1.先降级openssh-clien 执行sudo apt-get install openssh-client:=1:6.6p1-2ubuntu1,安装过程中会有降级的提示信息

  • 2.再次安装openssh-server 执行sudo apt-get install openssh-server